Welcome To GiantScaleNews.com

GSN is the BEST in an RC online community. Less corporate BS and more down home fun. Better conversations with REAL RC'ers. Don't settle for the biggest when you can have the best!
  1. If you are new to GiantScaleNews.com, please register, introduce yourself, and make yourself at home.

    We're 1st in Giant Scale RC because we've got the best membership on the internet! Take a look around and don't forget to register to get all of the benefits of GSN membership!

    Welcome!

Yippee! What the postman brought

Discussion in 'Giant / Scale RC General Discussions' started by stangflyer, Jul 30, 2018.

   
  1. I think you have to arm the speedo every time you install a battery. Just throttle up all the way, wait for it to beep several times. Then throttle down all the way. After that, it should work just fine.
     
    Snoopy1 and dhal22 like this.
  2. dhal22

    dhal22 GSN Sponsor Tier 1

    Hmmmmmm. If I get the prop to spin I'll have a functional plane AND it will blow the dust off the plane. This could be a good day. Thx
     
    pawnshopmike and Snoopy1 like this.
  3. BalsaDust

    BalsaDust Moderator

    It should arm itself from the get go though. Can you describe the beeps you get when you plug it up. If you get a little jingle then Beep, beep, beep, BEEEEEEEEEEEP then it should be armed and saying it has a 3S batt hooked up to it. If it just sits there and keeps beeping every 3-5 seconds then either your throttle channel needs to be reversed (common with Futaba), Your throttle trim is set to high, or the ESC might need to be calibrated. Personally I calibrate all of mine when new so their range matches the range of the throttle stick on my particular radio. to calibrate before plugging the battery in turn your radio on and go wide open throttle. plug battery in then wait for a few quick beeps. Once those quick beeps stop then pull the throttle stick back to idle and then the ESC should go through its normal arming process and you will be good to go.

    If the ESC is going through its normal arm process though and your still not getting any movement then I would start by trying either a different ESC or a different motor as its possible one or the other or both could be faulty.

    Sorry if I have just babbled on about something you may have already known. Just trying to help out as the tundra is a fun little plane to fly.
     
    Snoopy1, AKNick and dhal22 like this.
  4. dhal22

    dhal22 GSN Sponsor Tier 1


    I know nothing about electrics. Thank you very much. Will report back this weekend.
     
    BalsaDust and AKNick like this.
  5. Snoopy1

    Snoopy1 640cc Uber Pimp

    5,636
    7,936
    113
    Canada
    At last been waiting for this impatiently. It has arrived now I can continue with the Timber assembly.

    11E64F42-B477-4FAA-8B02-4461044D6BF6.jpeg
     
    pawnshopmike, AKNick and WMcNabb like this.
  6. AKNick

    AKNick 150cc

    1,933
    3,157
    113
    Alaska
    I like it! Where did you get it?
     
  7. Snoopy1

    Snoopy1 640cc Uber Pimp

    5,636
    7,936
    113
    Canada
    From Thunderbolt RC.
     
    AKNick likes this.
  8. dhal22

    dhal22 GSN Sponsor Tier 1

    Metal cutting bandsaw blade for my tabletop bandsaw. Was worried about the 14 TPI, could not find 18 TPI but it cuts fine. 20191031_172854.jpg


    15725590541291754265597.jpg
     
    acerc, WMcNabb and pawnshopmike like this.
  9. acerc

    acerc 640cc Uber Pimp

    2,750
    4,373
    113
    Florida
    Finally got the batteries in, changed the plugs, and tried it today. Man what a difference a cell make's, it's a keeper for sure now.
    Really nice to be able to walk out back and throw something up with out any hassle, the Tundra for extreme relaxation and the Extra 300 for a good bit more thrill!!!
     
    WMcNabb, Snoopy1 and pawnshopmike like this.
  10. TonyHallo

    TonyHallo 70cc twin V2

    While the postman didn't bring it, I scored this pile of balsa blocks for $20 at the MARC auction this morning. Most of the blocks are just over 4' long. I think I'm set for a while
    IMG_0506.JPG
     
    dhal22, BalsaDust, WMcNabb and 3 others like this.
Loading...
Similar Threads - postman brought
  1. njswede
    Replies:
    12
    Views:
    2,817

Share This Page